Note!
Routers use OSPF configuration from the lab 6.
Topology

Configuring authentication use the password: ‘cisco’.
Task 1
All loopback addresses should be advertised with their configured network mask (/24).
Task 2
Configure the strongest OSPF authentication between R2 and R3. On R3, enable authentication under the routing process (config-router) but make sure there is no OSPF authentication between R1 and R3.
Task 3
Enable Simple Password OSPF authentication in the area 1. R4 should have OSPF authentication enabled on F1/0 interface but not in the ‘config-router’ context.
Lab Solution
Task 1
On all loopback interfaces (all routers should already be configured with this as per lab 6):
All loopback addresses should be advertised with their configured network mask (/24).
Task 2
R2 Configuration:
ip address 10.1.23.2 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
R3 Configuration:
router-id 3.3.3.3
log-adjacency-changes
area 0 authentication message-digest
network 0.0.0.0 255.255.255.255 area 0
ip address 10.1.13.3 255.255.255.0
ip ospf authentication null
!
ip address 10.1.23.3 255.255.255.0
ip ospf message-digest-key 1 md5 cisco
!
Task 3
R1 Configuration:
router-id 1.1.1.1
log-adjacency-changes
area 1 authentication
network 10.1.13.1 0.0.0.0 area 0
network 10.1.124.1 0.0.0.0 area 1
network 172.16.101.1 0.0.0.0 area 0
ip address 10.1.124.1 255.255.255.0
ip ospf authentication-key cisco
ip ospf priority 20
!
R2 Configuration:
router-id 2.2.2.2
log-adjacency-changes
area 1 authentication
network 10.1.23.2 0.0.0.0 area 0
network 10.1.124.2 0.0.0.0 area 1
network 172.16.102.2 0.0.0.0 area 0
!
ip address 10.1.124.2 255.255.255.0
ip ospf authentication-key cisco
ip ospf priority 10
R4 Configuration:
router-id 4.4.4.4
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 1
!
ip address 10.1.124.4 255.255.255.0
ip ospf authentication
ip ospf authentication-key cisco
!
Verification